summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-12 03:24:12 -0400
committerMark H Weaver <mhw@netris.org>2015-06-13 23:01:07 -0400
commit4c50e5ab3a393c6d86fc6362c58f7ecf32dd9680 (patch)
tree1251c98b95b58326788e67c7e6f63bb2984e7f8f /gnu/packages
parent8c01b9d05aa5d5449398d5babdf7fa1fe95af1c2 (diff)
downloadguix-4c50e5ab3a393c6d86fc6362c58f7ecf32dd9680.tar.gz
gnu: python: Disable ssl test that fails with openssl-1.0.2b.
* gnu/packages/patches/python-disable-ssl-test.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/python.scm (python): Add patch.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/python-disable-ssl-test.patch12
-rw-r--r--gnu/packages/python.scm4
2 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/patches/python-disable-ssl-test.patch b/gnu/packages/patches/python-disable-ssl-test.patch
new file mode 100644
index 0000000000..e351c77505
--- /dev/null
+++ b/gnu/packages/patches/python-disable-ssl-test.patch
@@ -0,0 +1,12 @@
+Disable a test that fails with openssl-1.0.2b.
+
+--- Lib/test/test_ssl.py.orig	2015-02-25 06:27:45.000000000 -0500
++++ Lib/test/test_ssl.py	2015-06-12 03:14:09.395212502 -0400
+@@ -2718,6 +2718,7 @@
+                                        chatty=True, connectionchatty=True)
+             self.assertIs(stats['compression'], None)
+ 
++        @unittest.skipIf(True, "openssl 1.0.2b complains: dh key too small")
+         def test_dh_params(self):
+             # Check we can get a connection with ephemeral Diffie-Hellman
+             context = ssl.SSLContext(ssl.PROTOCOL_TLSv1)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 914c2dc23c..232a785778 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -207,7 +207,9 @@ data types.")
               (method url-fetch)
               (uri (string-append "https://www.python.org/ftp/python/"
                                   version "/Python-" version ".tar.xz"))
-              (patches (list (search-patch "python-fix-tests.patch")))
+              (patches (list (search-patch "python-fix-tests.patch")
+                             ;; XXX Try removing this patch for python > 3.4.3
+                             (search-patch "python-disable-ssl-test.patch")))
               (patch-flags '("-p0"))
               (sha256
                (base32