summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:50 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:34 +0200
commit4d6c24f5d1974bab56b52feb233ac653a6e37ae7 (patch)
treefdd824d2febd2b630dae79d11511b13b195ef263 /gnu/packages
parentd04fbb0d3e31db26aaafcfd0dad9308798348534 (diff)
downloadguix-4d6c24f5d1974bab56b52feb233ac653a6e37ae7.tar.gz
gnu: Add trytond-stock-location-sequence.
* gnu/packages/tryton.scm (trytond-stock-location-sequence): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tryton.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index ff86dbb132..d147709c6b 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3837,6 +3837,29 @@ define some Locations as movable
 (like palette).")
     (license license:gpl3+)))
 
+(define-public trytond-stock-location-sequence
+  (package
+    (name "trytond-stock-location-sequence")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_location_sequence" version))
+       (sha256
+        (base32 "0lpvgk5s7v30c0hicqc2m6apv8gzd1d6229yv1lrp2g62yp9pa9f"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_location_sequence"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-stock-location-sequence")
+    (synopsis "Tryton module to add sequence on location")
+    (description "The @emph{Stock Location Sequence} Tryton module adds
+ordering to location.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-lot
   (package
     (name "trytond-stock-lot")