summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-12-31 09:11:35 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-28 00:08:32 +1000
commit4dfa39cc67b4ca0f21d9d7794593f399c141625c (patch)
treef729eba738c8d6b450a8dd9c75d8f07e2d8dea2c /gnu/packages
parent4fea500bb1ce9da76b4f3f11b17ef108b87fdbcb (diff)
downloadguix-4dfa39cc67b4ca0f21d9d7794593f399c141625c.tar.gz
gnu: Add ruby-shoulda-context.
* gnu/packages/ruby.scm (ruby-shoulda-context): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index fd13d08e44..0dc3561fbb 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3190,6 +3190,35 @@ engine.")
      "https://github.com/sparklemotion/sqlite3-ruby")
     (license license:bsd-3)))
 
+(define-public ruby-shoulda-context
+  (package
+    (name "ruby-shoulda-context")
+    (version "1.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "shoulda-context" version))
+       (sha256
+        (base32
+         "06wv2ika5zrbxn0m3qxwk0zkbspxids3zmlq3xxays5qmvl1qb55"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             ;; Do not run tests to avoid circular dependence with rails.
+             ;; Instead just import the library to test.
+             (zero? (system* "ruby" "-Ilib" "-r" "shoulda-context")))))))
+    (synopsis "Test::Unit context framework extracted from Shoulda")
+    (description
+     "@code{shoulda-context} is the context framework extracted from Shoulda.
+Instead of writing Ruby methods with lots_of_underscores, shoulda-context adds
+context, setup, and should blocks combine to produce natural test method
+names.")
+    (home-page "https://github.com/thoughtbot/shoulda-context")
+    (license license:expat)))
+
 (define-public ruby-ansi
   (package
     (name "ruby-ansi")