summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-31 14:54:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-31 14:54:59 +0200
commit51d4c79dc28c70cde61348eb52775f45125a2ee7 (patch)
treeaff7bac3184a7a098ced498e1f961a0115cbe37b /gnu/packages
parentf9f72d35361bde53b8face634c72530aa7d81edf (diff)
downloadguix-51d4c79dc28c70cde61348eb52775f45125a2ee7.tar.gz
gnu: Remove workarounds for <https://bugs.gnu.org/36721>.
These are no longer needed since 941ef1a1e54893ca917ebbaa4b8cc14b5ce9b75c.

* gnu/packages/compression.scm (innoextract)[arguments]: Remove
"-DBoost_NO_BOOST_CMAKE=ON" from <#:configure-flags>.
* gnu/packages/game-development.scm (openmw)[arguments]: Likewise.
* gnu/packages/games.scm (supertux, colobot, leela-zero)[arguments]: Likewise.
* gnu/packages/graphics.scm (openimageio)[arguments]: Likewise.
* gnu/packages/ibus.scm (librime)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/compression.scm3
-rw-r--r--gnu/packages/game-development.scm3
-rw-r--r--gnu/packages/games.scm8
-rw-r--r--gnu/packages/graphics.scm5
-rw-r--r--gnu/packages/ibus.scm4
5 files changed, 4 insertions, 19 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index da9e646f5f..774abad5c9 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1822,9 +1822,6 @@ single-member files which can't be decompressed in parallel.")
    (build-system cmake-build-system)
    (arguments
     `(#:tests? #f
-      ;; XXX: Work around a problem with the CMake support in Boost 1.70:
-      ;; <https://github.com/dscharrer/innoextract/issues/88>.
-      #:configure-flags '("-DBoost_NO_BOOST_CMAKE=ON")
       #:phases (modify-phases %standard-phases
                  (add-before 'configure 'glibc-is-already-a-system-library
                    (lambda _
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5a4b81a988..7eac935a69 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1116,8 +1116,7 @@ of use.")
     (arguments
      `(#:tests? #f                      ; No test target
        #:configure-flags
-       (list "-DDESIRED_QT_VERSION=5"
-             "-DBoost_NO_BOOST_CMAKE=ON"))) ;work around <https://bugs.gnu.org/36721>
+       (list "-DDESIRED_QT_VERSION=5")))
     (native-inputs
      `(("boost" ,boost)
        ("doxygen" ,doxygen)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4e7fb2e428..66b642ebd2 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3516,8 +3516,6 @@ with the \"Stamp\" tool within Tux Paint.")
    (arguments
     '(#:tests? #f
       #:configure-flags '("-DINSTALL_SUBDIR_BIN=bin"
-                          ;; XXX: Work around <https://bugs.gnu.org/36721>.
-                          "-DBoost_NO_BOOST_CMAKE=ON"
                           "-DUSE_SYSTEM_PHYSFS=ON")
       #:phases
       (modify-phases %standard-phases
@@ -5390,8 +5388,6 @@ Github or Gitlab.")
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f                      ;no test
-       ;; XXX: Work around <https://bugs.gnu.org/36721>.
-       #:configure-flags '("-DBoost_NO_BOOST_CMAKE=ON")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'make-git-checkout-writable
@@ -7616,9 +7612,7 @@ remake of that series or any other game.")
       ("qtbase" ,qtbase)
       ("zlib" ,zlib)))
    (arguments
-    '(#:configure-flags '("-DUSE_BLAS=YES"
-                          ;; XXX: Work around <https://bugs.gnu.org/36721>.
-                          "-DBoost_NO_BOOST_CMAKE=ON")
+    '(#:configure-flags '("-DUSE_BLAS=YES")
       #:phases (modify-phases %standard-phases
                  (add-before 'configure 'fix-tests
                    (lambda* (#:key outputs #:allow-other-keys)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 66d47fdb84..f4f9228a07 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -467,10 +467,7 @@ storage of the \"EXR\" file format for storing 16-bit floating-point images.")
     ;; third party sources have to be present.  For details see
     ;; https://github.com/OpenImageIO/oiio/blob/master/INSTALL
     (arguments
-     `(#:tests? #f
-       ;; XXX: Work around a problem with Boost 1.70 and CMake 3.14.  See
-       ;; <https://bugs.gnu.org/36721> for details.
-       #:configure-flags '("-DBoost_NO_BOOST_CMAKE=ON")))
+     `(#:tests? #f))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 9291a74394..96fded0f4e 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -325,9 +325,7 @@ Japanese language input in most graphical applications.")
            #t))))
     (build-system cmake-build-system)
     (arguments
-     '(;; XXX: Work around <https://bugs.gnu.org/36721>.
-       #:configure-flags '("-DBoost_NO_BOOST_CMAKE=ON")
-       #:phases
+     '(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-source
            (lambda _