summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-11-27 21:33:57 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-11-30 15:50:25 +0100
commit5a4003f453ee8afdfe21d959e105250bfc876063 (patch)
treead5024bdbf28f4cd9827f3d0252f49ad8941bfea /gnu/packages
parent5696fbd9bdce53a0fbde66db81165ba29ea3f3ff (diff)
downloadguix-5a4003f453ee8afdfe21d959e105250bfc876063.tar.gz
gnu: Add ocaml-gen.
* gnu/packages/ocaml.scm (ocaml-gen): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4dd8aa68f5..75e66206b1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2000,6 +2000,31 @@ representation of the data.")
     (description "Lexer generator for Unicode and OCaml.")
     (license license:expat)))
 
+(define-public ocaml-gen
+  (package
+    (name "ocaml-gen")
+    (version "0.5.2")
+    (source (origin
+              (method url-fetch)
+              (uri "https://github.com/c-cube/gen/archive/0.5.2.tar.gz")
+              (sha256
+               (base32
+                "01hvvynh580zxsaqg12md8m17rda0l33avjv00pij44ql6676il2"))))
+    (build-system dune-build-system)
+    (arguments
+     `(#:tests? #f; no tests
+       #:package "gen"))
+    (propagated-inputs
+     `(("ocaml-odoc" ,ocaml-odoc)))
+    (native-inputs
+     `(("ocaml-qtest" ,ocaml-qtest)
+       ("ocaml-qcheck" ,ocaml-qcheck)))
+    (home-page "https://github.com/c-cube/gen/")
+    (synopsis "Iterators for OCaml, both restartable and consumable")
+    (description "Gen implements iterators of OCaml, that are both restartable
+and consumable.")
+    (license license:bsd-2)))
+
 (define-public ocaml-uchar
   (package
     (name "ocaml-uchar")