summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2021-08-18 19:07:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-08-18 19:07:50 +0200
commit62eb249f8ae5423ac7dc1bd56b529bfee1ffa3f0 (patch)
tree6438213db7a0d1b74f7f7f2ca3fb8e83ddc29afd /gnu/packages
parent9b2d2c622363bb93e91b38ad66642f0df3a67b4f (diff)
downloadguix-62eb249f8ae5423ac7dc1bd56b529bfee1ffa3f0.tar.gz
gnu: Add emacs-pcmpl-args.
* gnu/packages/emacs-xyz.scm (emacs-pcmpl-args): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 24fcfda835..bea6288976 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28411,6 +28411,28 @@ Features:
 @end itemize\n")
     (license license:gpl3+)))
 
+(define-public emacs-pcmpl-args
+  (package
+    (name "emacs-pcmpl-args")
+    (version "0.1.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JonWaltman/pcmpl-args.el")
+             (commit version)))
+       (sha256
+        (base32 "19xwwpfcf0l9jh7xixyjd5adivj27jw00zvxb7n1240k5p332pzi"))
+       (file-name (git-file-name name version))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/JonWaltman/pcmpl-args.el")
+    (synopsis "Enhanced shell command completion")
+    (description
+     "pcmpl-args extends option and argument completion of shell commands read
+by Emacs.  It is intended to make shell completion in Emacs comparable to the
+rather excellent completion provided by both Bash and Zsh.")
+    (license license:gpl3+)))
+
 (define-public emacs-shell-command+
   (package
     (name "emacs-shell-command+")