summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-04 00:21:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-04 00:21:27 +0100
commit630671d2e8c5f24bd14b7ea581108f76a54b2865 (patch)
tree804022d84e42fcca04e94956307ffa8f0c6f5c87 /gnu/packages
parent5cb2920b8dc61648eb8e61dadd2ee0b38ee93915 (diff)
downloadguix-630671d2e8c5f24bd14b7ea581108f76a54b2865.tar.gz
gnu: mafft: Replace references to %build-inputs and %outputs.
* gnu/packages/bioinformatics.scm (mafft)[arguments]: Replace references to
%outputs with a gexp; replace reference to %build-inputs in the 'wrap-programs
phase by binding INPUTS.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9d8a33df3f..0c75169d45 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5221,10 +5221,9 @@ sequencing tag position and orientation.")
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ; no automated tests, though there are tests in the read me
-       #:make-flags (let ((out (assoc-ref %outputs "out")))
-                      (list (string-append "PREFIX=" out)
-                            (string-append "BINDIR="
-                                           (string-append out "/bin"))))
+       #:make-flags ,#~(list (string-append "PREFIX=" #$output)
+                             (string-append "BINDIR="
+                                            (string-append #$output "/bin")))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'enter-dir
@@ -5264,11 +5263,11 @@ sequencing tag position and orientation.")
              #t))
          (delete 'configure)
          (add-after 'install 'wrap-programs
-           (lambda* (#:key outputs #:allow-other-keys)
+           (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (bin (string-append out "/bin"))
                     (path (string-append
-                           (assoc-ref %build-inputs "coreutils") "/bin:")))
+                           (assoc-ref inputs "coreutils") "/bin:")))
                (for-each (lambda (file)
                            (wrap-program file
                              `("PATH" ":" prefix (,path))))