summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-07 13:38:32 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-07-08 19:32:45 +0200
commit6702441f178bbe1e70286448864be7248693e6b4 (patch)
treea63dba711c3d1a060425ed75b08723ab72ccb65a /gnu/packages
parentfcac44c01253a723f4fec0e83178a553f9992a12 (diff)
downloadguix-6702441f178bbe1e70286448864be7248693e6b4.tar.gz
gnu: sbcl-moptilities: Remove sbcl-moptilities reference in cl-moptilities.
* gnu/packages/lisp-xyz.scm (sbcl-moptilities)[arguments]: Delete the
'test-results' folder.

This takes the closure size from 158 MiB down to 0 MiB :)
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lisp-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 71c0c586d7..47d7a3ef43 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10864,6 +10864,16 @@ compliance control.")
                (substitute* "lift-standard.config"
                  ((":relative-to lift-test")
                   ":relative-to moptilities-test"))
+               #t))
+           (add-after 'install 'remove-test-results
+             ;; Otherwise the drag the SBCL package into the closure of the CL
+             ;; package.
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let* ((out (assoc-ref outputs "out"))
+                      (source-path (string-append out "/share/common-lisp/"
+                                                  (%lisp-type) "/moptilities/")))
+                 (delete-file-recursively
+                  (string-append source-path "/test-results")))
                #t)))))
       (synopsis "Compatibility layer for Common Lisp MOP implementation differences")
       (description