summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-16 08:11:08 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:30 +0100
commit6e3cbafb60dd55c41dd5cab1f2ccf4077c7cc27a (patch)
tree6be59597a3a84e6c765a26f67f35cdeef4b4c1f6 /gnu/packages
parent1cc3971242fe28835b57e3e480c2336db04ca024 (diff)
downloadguix-6e3cbafb60dd55c41dd5cab1f2ccf4077c7cc27a.tar.gz
gnu: fontforge: Fix build with Python 3.8.
* gnu/packages/fontutils.scm (fontforge)[native-inputs]: Add AUTOCONF,
AUTOMAKE, and LIBTOOL.
[arguments]: Add phase 'fix-linking-with-python-3.8'.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/fontutils.scm21
1 files changed, 19 insertions, 2 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 34e17fdf67..1e5ebea868 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -9,7 +9,7 @@
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -585,7 +585,13 @@ definitions.")
              (base32 "0lh8yx01asbzxm6car5cfi64njh5p4lxc7iv8dldr5rwg357a86r"))))
    (build-system gnu-build-system)
    (native-inputs
-    `(("pkg-config" ,pkg-config)))
+    `(("pkg-config" ,pkg-config)
+
+      ;; TODO: Remove these inputs and the 'fix-linking-with-python-3.8' phase
+      ;; below when updating fontforge.
+      ("autoconf" ,autoconf)
+      ("automake" ,automake)
+      ("libtool" ,libtool)))
    (inputs `(("cairo"           ,cairo)
              ("fontconfig"      ,fontconfig) ;dlopen'd
              ("freetype"        ,freetype)
@@ -610,6 +616,17 @@ definitions.")
    (arguments
     '(#:phases
       (modify-phases %standard-phases
+        (add-before 'bootstrap 'fix-linking-with-python-3.8
+          (lambda _
+            ;; Applications that embed the Python interpreter are supposed to
+            ;; use the new "python-3.8-embed.pc" pkg-config file starting with
+            ;; Python 3.8.  Adjust the build system accordingly.
+            (substitute* "m4/fontforge_arg_enable.m4"
+              (("python-\"\\$\\{PYTHON_VERSION\\}\"" all)
+               (string-append all "-embed")))
+            ;; Delete the configure script in order to force autoreconf.
+            (delete-file "configure")
+            #t))
         (add-after 'install 'set-library-path
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out"))