summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-28 04:39:59 +0100
committerMarius Bakke <marius@gnu.org>2022-12-02 00:21:24 +0100
commit6f0a8371feb7f349ec799bd31a547bd7e40d2f67 (patch)
treedabd47cbbd5516c193c8c3283d615a07af3a5ebf /gnu/packages
parente069db7e30bc9d99e5b7f8cbf4d43296150aa552 (diff)
downloadguix-6f0a8371feb7f349ec799bd31a547bd7e40d2f67.tar.gz
gnu: gn: Use G-expression.
* gnu/packages/build-tools.scm (gn)[arguments]: Convert to G-expression.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/build-tools.scm68
1 files changed, 35 insertions, 33 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index a7a3ff2fa4..6c1350c44f 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -219,22 +219,24 @@ programs and other files depend.")
                 (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (arguments
-       `(#:phases (modify-phases %standard-phases
-                    (add-before 'configure 'set-build-environment
-                      (lambda _
-                        (setenv "CC" "gcc") (setenv "CXX" "g++")
-                        (setenv "AR" "ar")))
-                    (replace 'configure
-                      (lambda _
-                        (invoke "python" "build/gen.py"
-                                "--no-last-commit-position")))
-                    (add-after 'configure 'create-last-commit-position
-                      (lambda _
-                        ;; Mimic GenerateLastCommitPosition from gen.py.
-                        (call-with-output-file "out/last_commit_position.h"
-                          (lambda (port)
-                            (format port
-                                    "// Generated by Guix.
+       (list #:phases
+             #~(modify-phases %standard-phases
+                 (add-before 'configure 'set-build-environment
+                   (lambda _
+                     (setenv "CC" "gcc")
+                     (setenv "CXX" "g++")
+                     (setenv "AR" "ar")))
+                 (replace 'configure
+                   (lambda _
+                     (invoke "python" "build/gen.py"
+                             "--no-last-commit-position")))
+                 (add-after 'configure 'create-last-commit-position
+                   (lambda _
+                     ;; Mimic GenerateLastCommitPosition from gen.py.
+                     (call-with-output-file "out/last_commit_position.h"
+                       (lambda (port)
+                         (format port
+                                 "// Generated by Guix.
 
 #ifndef OUT_LAST_COMMIT_POSITION_H_
 #define OUT_LAST_COMMIT_POSITION_H_
@@ -244,23 +246,23 @@ programs and other files depend.")
 
 #endif  // OUT_LAST_COMMIT_POSITION_H_
 "
-                                    ,revision ,revision ,(string-take commit 12))))))
-                    (replace 'build
-                      (lambda _
-                        (invoke "ninja" "-C" "out" "gn"
-                                "-j" (number->string (parallel-job-count)))))
-                    (replace 'check
-                      (lambda* (#:key tests? #:allow-other-keys)
-                        (if tests?
-                            (begin
-                              (invoke "ninja" "-C" "out" "gn_unittests"
-                                      "-j" (number->string (parallel-job-count)))
-                              (invoke "./out/gn_unittests"))
-                            (format #t "test suite not run~%"))))
-                    (replace 'install
-                      (lambda* (#:key outputs #:allow-other-keys)
-                        (let ((out (assoc-ref outputs "out")))
-                          (install-file "out/gn" (string-append out "/bin"))))))))
+                                 #$revision #$revision
+                                 #$(string-take commit 12))))))
+                 (replace 'build
+                   (lambda _
+                     (invoke "ninja" "-C" "out" "gn"
+                             "-j" (number->string (parallel-job-count)))))
+                 (replace 'check
+                   (lambda* (#:key tests? #:allow-other-keys)
+                     (if tests?
+                         (begin
+                           (invoke "ninja" "-C" "out" "gn_unittests"
+                                   "-j" (number->string (parallel-job-count)))
+                           (invoke "./out/gn_unittests"))
+                         (format #t "test suite not run~%"))))
+                 (replace 'install
+                   (lambda _
+                     (install-file "out/gn" (string-append #$output "/bin")))))))
       (native-inputs
        (list ninja python-wrapper))
       (synopsis "Generate Ninja build files")