summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-23 13:14:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-23 13:25:01 +0200
commit7628430a2f46a4a57d5ff7e51b1be80b7765c96c (patch)
tree26974c48ad80739e7a7b06cc00eaff368e17cf27 /gnu/packages
parent196e3f52355ee7d086e67eb769d714dd040d61c2 (diff)
downloadguix-7628430a2f46a4a57d5ff7e51b1be80b7765c96c.tar.gz
gnu: php: Update to 7.4.25 [security fixes].
* gnu/packages/php.scm (php): Update to 7.4.25.
[source]: Don't explicitly return #t from snippet.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/php.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index e6df1e6666..c4d5856325 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -60,7 +60,7 @@
 (define-public php
   (package
     (name "php")
-    (version "7.4.22")
+    (version "7.4.25")
     (home-page "https://secure.php.net/")
     (source (origin
               (method url-fetch)
@@ -68,7 +68,7 @@
                                   "php-" version ".tar.xz"))
               (sha256
                (base32
-                "1s5xjy1cchlg0vfxic73wy2wip8spfjr094hzzyc76plsbbqq1wf"))
+                "02iw75niazf3zh3ry15k5yjy6ivg49rwzlr8g8w49rgyszqmi9qj"))
               (patches (search-patches "php-bug-74093-test.patch"))
               (modules '((guix build utils)))
               (snippet
@@ -82,8 +82,7 @@
                             ;;"fileinfo/libmagic" ; a patched version of libmagic
                             '("gd/libgd"
                               "pcre/pcre2lib"
-                              "xmlrpc/libxmlrpc"))
-                  #t))))
+                              "xmlrpc/libxmlrpc"))))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags