summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-01-19 19:54:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-20 15:38:03 +0100
commit793f2edbbc572e83612cb9ac5a7f685d46216cd4 (patch)
treeeb42a6bcec441ade0b723236760280eab49b7b98 /gnu/packages
parentefba686c8056cf1ac65111ebe57e49c5218cb157 (diff)
downloadguix-793f2edbbc572e83612cb9ac5a7f685d46216cd4.tar.gz
gnu: Add r-lars.
* gnu/packages/statistics.scm (r-lars): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 33145d35bc..b4f8152b28 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4097,3 +4097,29 @@ letters, as is often required for scientific publications.")
      "This package provides a collection of R functions for analyzing finite
 mixture models.")
     (license license:gpl2+)))
+
+(define-public r-lars
+  (package
+    (name "r-lars")
+    (version "1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "lars" version))
+       (sha256
+        (base32
+         "0blj44wqrx6lmym1m9v6wkz8zxzbjax2zl6swgdczci0ixb5nx34"))))
+    (build-system r-build-system)
+    (inputs
+     `(("gfortran" ,gfortran)))
+    (home-page "http://www-stat.stanford.edu/~hastie/Papers/#LARS")
+    (synopsis "Least angle regression software")
+    (description
+     "Least Angle Regression (\"LAR\") is a model selection algorithm; a
+useful and less greedy version of traditional forward selection methods.  A
+simple modification of the LAR algorithm implements Tibshirani's Lasso; the
+Lasso modification of LARS calculates the entire Lasso path of coefficients
+for a given problem at the cost of a single least squares fit.  Another LARS
+modification efficiently implements epsilon Forward Stagewise linear
+regression.")
+    (license license:gpl2)))