summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-25 16:38:17 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-02 14:11:54 +0100
commit810cff855774f982b503e4a89b2426d210fbad6e (patch)
treeca83bf0e7215e2495e4a52a41a26cdbb51f20073 /gnu/packages
parent240ca4aae7cb109cc03f14066be3e2293fd65ec8 (diff)
downloadguix-810cff855774f982b503e4a89b2426d210fbad6e.tar.gz
gnu: Add CLIPper.
* gnu/packages/bioinformatics.scm (clipper): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2d6251ac92..de25f8c7b5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -234,6 +234,44 @@ gapped, local, and paired-end alignment modes.")
     (supported-systems '("x86_64-linux"))
     (license license:gpl3+)))
 
+(define-public clipper
+  (package
+    (name "clipper")
+    (version "0.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/YeoLab/clipper/archive/"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1q7jpimsqln7ic44i8v2rx2haj5wvik8hc1s2syd31zcn0xk1iyq"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; remove unnecessary setup dependency
+               '(substitute* "setup.py"
+                  (("setup_requires = .*") "")))))
+    (build-system python-build-system)
+    (arguments `(#:python ,python-2)) ; only Python 2 is supported
+    (inputs
+     `(("htseq" ,htseq)
+       ("python-pybedtools" ,python2-pybedtools)
+       ("python-cython" ,python2-cython)
+       ("python-scikit-learn" ,python2-scikit-learn)
+       ("python-matplotlib" ,python2-matplotlib)
+       ("python-pysam" ,python2-pysam)
+       ("python-numpy" ,python2-numpy)
+       ("python-scipy" ,python2-scipy)))
+    (native-inputs
+     `(("python-mock" ,python2-mock) ; for tests
+       ("python-pytz" ,python2-pytz) ; for tests
+       ("python-setuptools" ,python2-setuptools)))
+    (home-page "https://github.com/YeoLab/clipper")
+    (synopsis "CLIP peak enrichment recognition")
+    (description
+     "CLIPper is a tool to define peaks in CLIP-seq datasets.")
+    (license license:gpl2)))
+
 (define-public flexbar
   (package
     (name "flexbar")