summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-08 20:58:19 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-08 21:56:01 +0100
commit84f1e12b8b84acca1b3be7d41daacce28feb391d (patch)
tree9e5b968ffe664a050902f9e6492df467d0ff2a84 /gnu/packages
parentf09948fd442c22f0b1873ff40b64827a0bbe8a2c (diff)
downloadguix-84f1e12b8b84acca1b3be7d41daacce28feb391d.tar.gz
gnu: python-pyopenssl: Fix test failure.
* gnu/packages/python-crypto.scm (python-pyopenssl)[native-inputs]: Add LIBFAKETIME.
[arguments]: Use it to run tests with a fixed date.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-crypto.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 63d3be17c2..b9e32109ae 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
 ;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
@@ -448,7 +448,10 @@ message digests and key derivation functions.")
          (add-after 'install 'check
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (add-installed-pythonpath inputs outputs)
-             (invoke "py.test" "-v" "-k"
+             ;; PyOpenSSL runs tests against a certificate with a fixed
+             ;; expiry time.  To ensure successful builds in the future,
+             ;; set the time to roughly the release date.
+             (invoke "faketime" "2019-01-01" "py.test" "-v" "-k"
                      (string-append
                       ;; This test tries to look up certificates from
                       ;; the compiled-in default path in OpenSSL, which
@@ -463,7 +466,8 @@ message digests and key derivation functions.")
     (inputs
      `(("openssl" ,openssl)))
     (native-inputs
-     `(("python-flaky" ,python-flaky)
+     `(("libfaketime" ,libfaketime)
+       ("python-flaky" ,python-flaky)
        ("python-pretend" ,python-pretend)
        ("python-pytest" ,python-pytest)))
     (home-page "https://github.com/pyca/pyopenssl")