summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-11-27 12:08:59 -0500
committerLeo Famulari <leo@famulari.name>2016-12-20 14:50:19 -0500
commit8cb3e7e7defe9a75600f4cbf53d5032cd597e867 (patch)
tree78fac604e0707d22e68001112a4c2516bb974e1f /gnu/packages
parent4f6ff977c22b996765178a1dcc6e8f1523601817 (diff)
downloadguix-8cb3e7e7defe9a75600f4cbf53d5032cd597e867.tar.gz
gnu: borg: Update to 1.0.9.
* gnu/packages/backup.scm (borg): Update to 1.0.9.
[arguments]: Run the check phase in its own directory. Skip the test
'test_get_security_dir'.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/backup.scm43
1 files changed, 22 insertions, 21 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 6f88dae789..86c6712edc 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -404,13 +404,13 @@ detection, and lossless compression.")
 (define-public borg
   (package
     (name "borg")
-    (version "1.0.8")
+    (version "1.0.9")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "borgbackup" version))
               (sha256
                (base32
-                "1fdfi0yzzdrrlml6780n4fh61sqm7pw6fcd1y67kfkvw8hy5c0k9"))
+                "1ciwp9yilcibk0x82y5nn8ps95jrm8rxvff8mjrlp7a2w100i1im"))
               (modules '((guix build utils)))
               (snippet
                '(for-each
@@ -439,25 +439,26 @@ detection, and lossless compression.")
            (lambda* (#:key inputs outputs #:allow-other-keys)
              ;; Make the installed package available for the test suite.
              (add-installed-pythonpath inputs outputs)
-             (zero?
-               (system* "py.test" "-v" "--pyargs" "borg.testsuite" "-k"
-                        (string-append
-                          ;; These tests need to write to '/var'.
-                          "not test_get_cache_dir "
-                          "and not test_get_keys_dir "
-                          ;; These tests assume there is a root user in
-                          ;; '/etc/passwd'.
-                          "and not test_access_acl "
-                          "and not test_default_acl "
-                          "and not test_non_ascii_acl "
-                          ;; This test needs the unpackaged pytest-benchmark.
-                          "and not benchmark "
-                          ;; These tests assume the kernel supports FUSE. They
-                          ;; were skipped using the "old" Python build system,
-                          ;; before commit
-                          ;; 7db40bce58e149ecb541d295e01cfbfe953d39a3.
-                          "and not test_fuse "
-                          "and not test_fuse_allow_damaged_files")))))
+             ;; The tests should be run in an empty directory.
+             (mkdir-p "tests")
+             (with-directory-excursion "tests"
+               (zero?
+                 (system* "py.test" "-v" "--pyargs" "borg.testsuite" "-k"
+                          (string-append
+                            ;; These tests need to write to '/var'.
+                            "not test_get_cache_dir "
+                            "and not test_get_keys_dir "
+                            "and not test_get_security_dir "
+                            ;; These tests assume there is a root user in
+                            ;; '/etc/passwd'.
+                            "and not test_access_acl "
+                            "and not test_default_acl "
+                            "and not test_non_ascii_acl "
+                            ;; This test needs the unpackaged pytest-benchmark.
+                            "and not benchmark "
+                            ;; These tests assume the kernel supports FUSE.
+                            "and not test_fuse "
+                            "and not test_fuse_allow_damaged_files"))))))
          (add-after 'install 'install-doc
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))