summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-02-15 18:25:27 -0500
committerLeo Famulari <leo@famulari.name>2016-02-15 18:48:36 -0500
commit97bbc48023c8ae4d81020d0c9c85d2e29a633db1 (patch)
treee450e0bf5c4b2fbc909b7cb26d1d83158798c98a /gnu/packages
parent85a94d296ee109aed64bbde0570df10556ba2e54 (diff)
downloadguix-97bbc48023c8ae4d81020d0c9c85d2e29a633db1.tar.gz
gnu: python-lxml: Update to 3.5.0.
* gnu/packages/python.scm (python-lxml, python2-lxml): Update to 3.5.0.
[source]: Use pypi-uri.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 805c4a23b0..d17a17b527 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4474,17 +4474,14 @@ translate the complete SQLite API into Python.")
 (define-public python-lxml
   (package
     (name "python-lxml")
-    (version "3.4.2")
+    (version "3.5.0")
     (source
       (origin
         (method url-fetch)
-        (uri (string-append
-              "https://pypi.python.org/packages/source/l/lxml/lxml-"
-              version
-              ".tar.gz"))
+        (uri (pypi-uri "lxml" version))
         (sha256
           (base32
-            "0pd23qz8vms1mgm41p96h4vac5y91igs4wr9640gnvxgk019kmf7"))))
+            "0y7m2s8ci6q642zl85y5axkj8z827l0vhjl532acb75hlkir77rl"))))
     (build-system python-build-system)
     (inputs
       `(("libxml2" ,libxml2)