summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-02-11 23:30:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-02-28 22:29:47 +0100
commit982471276be6042860ad3f36ca62a89afe50f61f (patch)
tree60937a9eb91da8295e89cfad5b57689714ce1bf7 /gnu/packages
parentdd6b54b8460065d8c4531a09b20ddfaafc111bac (diff)
downloadguix-982471276be6042860ad3f36ca62a89afe50f61f.tar.gz
gnu: Add LV2 mda Piano plugin.
* gnu/packages/audio.scm (lv2-mdapiano): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/audio.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 52feea3701..0460fde727 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -498,6 +498,39 @@ add functionality to support the needs of increasingly powerful audio
 software.")
     (license license:isc)))
 
+(define-public lv2-mda-piano
+  (package
+    (name "lv2-mda-piano")
+    (version "0.0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitorious.org/lv2-synths/lv2-mdametapiano.git")
+                    (commit version)))
+              (sha256
+               (base32
+                "07lywf6lpfpndg3i9w752mmlg2hgn1bwp23h8b0mdj6awh67abqd"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags (list
+                     "TYPE=mdaPiano"
+                     (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:tests? #f ; no check target
+       #:phases (alist-delete 'configure %standard-phases)))
+    (inputs
+     `(("lv2" ,lv2)
+       ("lvtk" ,lvtk)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
+    (home-page "http://elephly.net/lv2/mdapiano.html")
+    (synopsis "LV2 port of the mda Piano plugin")
+    (description "An LV2 port of the mda Piano VSTi.")
+    (license license:gpl3+)))
+
 (define-public lvtk
   (package
     (name "lvtk")