summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-06-30 19:02:42 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-06-30 20:01:37 +0200
commit995409022f7dc6c2e284514fad34c09506ca15b3 (patch)
tree6d03208d9bcdf3570414c8ad67e2ab9f08b4933c /gnu/packages
parent0eac11139a770703399751ea092419909203a8a8 (diff)
downloadguix-995409022f7dc6c2e284514fad34c09506ca15b3.tar.gz
gnu: Add sb-cga.
* gnu/packages/lisp-xyz.scm (cl-sb-cga, ecl-sb-cga, sbcl-sb-cga): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lisp-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2eb960d53a..f13bbcc536 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -22162,3 +22162,36 @@ is performed for all defined operations.")
 
 (define-public ecl-physical-quantities
   (sbcl-package->ecl-package sbcl-physical-quantities))
+
+(define-public sbcl-sb-cga
+  (let ((commit "9a554ea1c01cac998ff7eaa5f767bc5bcdc4c094"))
+    (package
+      (name "sbcl-sb-cga")
+      (version (git-version "1.0.1" "1" commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/nikodemus/sb-cga/")
+               (commit commit)))
+         (file-name (git-file-name "cl-sb-cga" version))
+         (sha256
+          (base32 "1y54qlwfrhch9aghk7nsbdx7x2qsvgsws1g2k631l9dsgdakw4w8"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       (list sbcl-alexandria))
+      (home-page "https://github.com/nikodemus/sb-cga/")
+      (synopsis "Computer graphic algebra for Common Lisp")
+      (description
+       "SB-CGA is a computer graphics algebra library for Common Lisp.
+
+Despite the prefix it is actually portable - but optimizations that make it
+fast (using SIMD instructions) are currently implemented for SBCL/x86-64
+only.")
+      (license license:expat))))
+
+(define-public cl-sb-cga
+  (sbcl-package->cl-source-package sbcl-sb-cga))
+
+(define-public ecl-sb-cga
+  (sbcl-package->ecl-package sbcl-sb-cga))