summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 11:46:42 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:49 +0200
commit9a7f1575713be1050eedc611047b9603fdbd1bf6 (patch)
tree4e1afc277c76f9ddbf0173d5bcfba252f6816a29 /gnu/packages
parent90f2a8480518555a2eb3b8fa0cb3616fdab0ccb8 (diff)
downloadguix-9a7f1575713be1050eedc611047b9603fdbd1bf6.tar.gz
gnu: Add go-github-com-spaolacci-murmur3.
* gnu/packages/golang.scm (go-github-com-spaolacci-murmur3): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6174f756b8..d8126d8916 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2847,3 +2847,31 @@ In addition to AVX there is also support for AVX2 as well as SSE.  Best
 performance is obtained with AVX2 which gives roughly a 4X performance
 increase approaching hashing speeds of 1GB/sec on a single core.")
       (license license:asl2.0))))
+
+(define-public go-github-com-spaolacci-murmur3
+  (let ((commit "f09979ecbc725b9e6d41a297405f65e7e8804acc")
+        (revision "0"))
+    (package
+      (name "go-github-com-spaolacci-murmur3")
+      (version (git-version "1.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/spaolacci/murmur3.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1lv3zyz3jy2d76bhvvs8svygx66606iygdvwy5cwc0p5z8yghq25"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/spaolacci/murmur3"))
+      (home-page "https://github.com/spaolacci/murmur3")
+      (synopsis "Native MurmurHash3 Go implementation")
+      (description "Native Go implementation of Austin Appleby's third
+MurmurHash revision (aka MurmurHash3).
+
+Reference algorithm has been slightly hacked as to support the streaming mode
+required by Go's standard Hash interface.")
+      (license license:bsd-3))))