summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-26 10:55:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-26 11:25:20 +0200
commit9f120e9150ae51cf6274479e9b6441f09b6a93dc (patch)
tree831141b4baaab98c4003f41815419e621cd2d695 /gnu/packages
parented531c6cd9a24fd09769c5c081acb76e8191daa9 (diff)
downloadguix-9f120e9150ae51cf6274479e9b6441f09b6a93dc.tar.gz
gnu: Add r-ztpln.
* gnu/packages/cran.scm (r-ztpln): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5593b1a8f7..8499b2a44f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -30424,3 +30424,32 @@ calculated, functions for testing distributions using inversion tests and the
 Massart inequality.  Also included is an implementation of the incomplete
 Bessel K function.")
     (license license:gpl2+)))
+
+(define-public r-ztpln
+  (package
+    (name "r-ztpln")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ztpln" version))
+       (sha256
+        (base32
+         "18rbfdp22jaxg4nkqzj2393nhjdl1gzv4xhmr6aci76ymdixsfnl"))))
+    (properties `((upstream-name . "ztpln")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-distributionutils" ,r-distributionutils)
+       ("r-mixtools" ,r-mixtools)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rcppeigen" ,r-rcppeigen)
+       ("r-rcppnumerical" ,r-rcppnumerical)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/mattocci27/ztpln")
+    (synopsis "Zero-truncated Poisson lognormal distribution")
+    (description
+     "This package provides functions for obtaining the density, random
+variates and maximum likelihood estimates of the Zero-truncated Poisson
+lognormal distribution and their mixture distribution.")
+    (license license:expat)))