summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-02-09 01:44:45 -0500
committerLeo Famulari <leo@famulari.name>2016-02-12 18:50:32 -0500
commita14600ecfa6d4304418cda8668dfefdc2c1ce715 (patch)
tree5c07fd1f1470c5b4bee7883039d8a8e4a1096713 /gnu/packages
parent519e2f4fde768b0edc16cae75faea55abefa39eb (diff)
downloadguix-a14600ecfa6d4304418cda8668dfefdc2c1ce715.tar.gz
gnu: python-jsonschema: Define 'python2-variant'.
* gnu/packages/python.scm (python-jsonschema)[properties]: New field.
(python2-jsonschema): Use 'strip-python2-variant'.
* gnu/packages/openstack.scm (python2-tempest-lib): Take the result of
'package-with-python2' directly.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/openstack.scm7
-rw-r--r--gnu/packages/python.scm6
2 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index e258b89e2f..9a42a91340 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -392,12 +392,7 @@ common features used in Tempest.")
     (license asl2.0)))
 
 (define-public python2-tempest-lib
-  (let ((tempest-lib (package-with-python2 python-tempest-lib)))
-    (package (inherit tempest-lib)
-      (propagated-inputs
-       `(("python2-jsonschema", python2-jsonschema)
-         ,@(alist-delete "python-jsonschema"
-                         (package-propagated-inputs tempest-lib)))))))
+  (package-with-python2 python-tempest-lib))
 
 ;; Packages from the Oslo library
 (define-public python-oslo.config
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fc8582f2f4..f444cdbb64 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2241,10 +2241,12 @@ version numbers.")
     (synopsis "Implementation of JSON Schema for Python")
     (description
      "Jsonschema is an implementation of JSON Schema for Python.")
-    (license license:expat)))
+    (license license:expat)
+    (properties `((python2-variant . ,(delay python2-jsonschema))))))
 
 (define-public python2-jsonschema
-  (let ((jsonschema (package-with-python2 python-jsonschema)))
+  (let ((jsonschema (package-with-python2
+                     (strip-python2-variant python-jsonschema))))
     (package (inherit jsonschema)
       (inputs
        `(("python2-functools32" ,python2-functools32)