summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAlberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>2020-10-22 17:16:23 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-22 17:18:24 -0400
commita49bfa1f6c22363c9e495070f51b82e60b1495af (patch)
tree9d936c89e327c568167aac4e8e7a7105fe13d164 /gnu/packages
parent408912b076b092730ce461c5f67b76b7c00f8882 (diff)
downloadguix-a49bfa1f6c22363c9e495070f51b82e60b1495af.tar.gz
gnu: Add emacs-typing.
* gnu/packages/emacs-xyz.scm (emacs-typing): New variable.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d0158479bb..49bb82084e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -738,6 +738,30 @@ then only the color of the mode line changes when a window becomes in-/active.")
 clojure.walk and clojure.zip respectively.")
     (license license:gpl3+)))
 
+(define-public emacs-typing
+  (let ((commit "a2ef25dde2d8eb91bd9c0c6164cb5208208647fa")
+        (revision "0"))
+    (package
+      (name "emacs-typing")
+      (version (git-version "1.1.4" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/kensanata/typing")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1dbh0srbf54lgd60ia79y9cfnq3kxlgw01qzdjs9mk3nfazzpgnv"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/kensanata/typing/")
+      (synopsis "Emacs game where you have to type fast")
+      (description "The Typing of Emacs is a game for Emacs that
+forces you to type words correctly as fast as possible, otherwise
+you will die.  The game builds the list of words from the active buffer.")
+      (license license:gpl2+))))
+
 (define-public emacs-graphql
   (package
     (name "emacs-graphql")