summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-01-23 21:58:04 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-01-23 22:10:18 +0100
commita78364e91cca5faefc3d24619813487053bd6542 (patch)
tree188714acb065036a304b38dae22728a695214470 /gnu/packages
parent48446f0f94036e87c55e6e883abf9d75de5d1868 (diff)
downloadguix-a78364e91cca5faefc3d24619813487053bd6542.tar.gz
gnu: Add ne.
* gnu/packages/text-editors.scm (ne): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/text-editors.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 863ac7e584..607df4bb03 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -60,6 +60,7 @@
   #:use-module (gnu packages regex)
   #:use-module (gnu packages ruby)
   #:use-module (gnu packages terminals)
+  #:use-module (gnu packages texinfo)
   #:use-module (gnu packages xml))
 
 (define-public vis
@@ -717,3 +718,45 @@ card.  It offers:
 @item Compose function for Latin 1 characters
 @end itemize")
     (license license:gpl2+)))
+
+(define-public ne
+  (package
+    (name "ne")
+    (version "3.2.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/vigna/ne.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0h6d08cnwrk96ss83i9bragwwanph6x54sm3ak1z81146dsqsiif"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("perl" ,perl)
+       ("texinfo" ,texinfo)))
+    (inputs
+     `(("ncurses" ,ncurses)))
+    (arguments
+     `(#:tests? #f
+       #:make-flags
+       (list "CC=gcc"
+             (string-append "PREFIX=" (assoc-ref %outputs "out"))
+             (string-append "LDFLAGS=-L" (assoc-ref %build-inputs "ncurses")
+                            "/lib"))
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda _
+             (substitute* "src/makefile"
+              (("-lcurses") "-lncurses"))
+             #t)))))
+    (home-page "http://ne.di.unimi.it/")
+    (synopsis "Text editor with menu bar")
+    (description "This package provides a modeless text editor with menu bar.
+It supports syntax highlighting, regular expressions, configurable menus,
+keybindings, autocomplete and unlimited undo.  It can pipe a marked block
+of text through any command line filter.  It can also open very large binary
+files.  It was originally developed on the Amiga 3000T.")
+    (license license:gpl3+)))