summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-09-17 10:37:09 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-09-17 10:40:42 +0200
commitaa6a3976798ad9bf3b999c32d20cade83b900e65 (patch)
treede5055c8bc827c3078b93af521bad2b709cf723b /gnu/packages
parent05605998b2f70403c360ad5e27d942cef2b9502c (diff)
downloadguix-aa6a3976798ad9bf3b999c32d20cade83b900e65.tar.gz
gnu: sudo: Omit snippet and phase return value.
* gnu/packages/admin.scm (sudo)[source]: Don't return #t from snippet.
[argument]: Nor from the 'pre-configure phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c7e83cd4cf..1256dedfac 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1683,8 +1683,7 @@ system administrator.")
               (modules '((guix build utils)))
               (snippet
                '(begin
-                  (delete-file-recursively "lib/zlib")
-                  #t))))
+                  (delete-file-recursively "lib/zlib")))))
     (build-system gnu-build-system)
     (outputs (list "out"))
     (arguments
@@ -1737,8 +1736,7 @@ system administrator.")
              ;; not the task of the build system, and fails.
              (substitute* "plugins/sudoers/Makefile.in"
                (("^pre-install:" match)
-                (string-append match "\ndisabled-" match)))
-             #t)))
+                (string-append match "\ndisabled-" match))))))
 
        ;; XXX: The 'testsudoers' test series expects user 'root' to exist, but
        ;; the chroot's /etc/passwd doesn't have it.  Turn off the tests.