summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 10:36:45 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 17:37:40 +0100
commitaaf75c890b5242d3ab3671766226bc53ab07049a (patch)
treeba4cccb93365a7d603c15ee8b60f860af05be4cd /gnu/packages
parent043a51c0c2a025b84b0fb14c157add7236d7a526 (diff)
downloadguix-aaf75c890b5242d3ab3671766226bc53ab07049a.tar.gz
gnu: ensure pip and setuptools are installed even for Python 2.
* gnu/packages/python.scm (python-2.7): Add "--with-ensurepip=install" to
  configure-flags.
* doc/guix.texi (Python Modules): Document it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 18e485ab2e..b6aeb8c032 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -162,6 +162,7 @@
        #:configure-flags
        (list "--enable-shared"                    ;allow embedding
              "--with-system-ffi"                  ;build ctypes
+             "--with-ensurepip=install"           ;install pip and setuptools
              (string-append "LDFLAGS=-Wl,-rpath="
                             (assoc-ref %outputs "out") "/lib"))