summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-03-30 13:18:25 +0530
committerLudovic Courtès <ludo@gnu.org>2018-03-30 23:42:07 +0200
commitabc4a3325ecd666f9fa9f7ddccc1793e9fa30d6d (patch)
tree1c763d9566c4704d73d3a3a912e907e64ece1269 /gnu/packages
parent602a148650809da3c2356e4429f4b8160a72843b (diff)
downloadguix-abc4a3325ecd666f9fa9f7ddccc1793e9fa30d6d.tar.gz
gnu: Add pinentry-emacs.
* gnu/packages/gnupg.scm (pinentry-emacs): New variable.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnupg.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index c561c14ca7..a938c46167 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -38,6 +38,7 @@
   #:use-module (gnu packages base)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages crypto)
+  #:use-module (gnu packages emacs)
   #:use-module (gnu packages openldap)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages perl-check)
@@ -738,6 +739,16 @@ including tools for signing keys, keyring analysis, and party preparation.
                   (ftp-directory . "/gcrypt/pinentry")
                   (upstream-name . "pinentry")))))
 
+(define-public pinentry-emacs
+  (package
+    (inherit pinentry-tty)
+    (name "pinentry-emacs")
+    (arguments
+     `(#:configure-flags '("--enable-pinentry-emacs")))
+    (description
+     "Pinentry provides a console and an Emacs interface that allows users to
+enter a passphrase when required by @code{gpg} or other software.")))
+
 (define-public pinentry-gtk2
   (package
     (inherit pinentry-tty)