summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 12:59:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 17:03:07 +0200
commitad39b6d88f42249facd1ea09ca30c3ead641def0 (patch)
treefc15c9d205afc6d98343b3c1d9382b4f878b9064 /gnu/packages
parentff3bc20c9675b6c4b09969eac8345e766c0c3332 (diff)
downloadguix-ad39b6d88f42249facd1ea09ca30c3ead641def0.tar.gz
gnu: Add texlive-alg.
* gnu/packages/tex.scm (texlive-alg): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 54390f1c77..ce5045215e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1246,6 +1246,29 @@ ligatures, but also offers additional control over them.")
 a given (Unicode) glyph.  It relies on Fontconfig.")
     (license license:bsd-3)))
 
+(define-public texlive-alg
+  (package
+    (name "texlive-alg")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/alg/" "source/latex/alg/"
+                   "tex/latex/alg/")
+             (base32
+              "0jqk9sgw2m4c6hssfc5c3qfxqvpyppvcmy8i5crm7fsmkv0y6wkg")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/alg")
+    (synopsis "LaTeX environments for typesetting algorithms")
+    (description
+     "The package defines two environments for typesetting algorithms in LaTeX2e.
+The @code{algtab} environment is used to typeset an algorithm with
+automatically numbered lines.  The @code{algorithm} environment can be used to
+encapsulate the @code{algtab} environment algorithm in a floating body
+together with a header, a caption, etc.  @code{\\listofalgorithms} is
+defined.")
+    (license license:lppl)))
+
 (define-public texlive-apnum
   (package
     (name "texlive-apnum")