summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:12:21 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:17 +0300
commitb91e17243187d342a5d67cb61934dfb6567acfc6 (patch)
tree331458bc5b19208c7414d880226f8162d01434bd /gnu/packages
parentfcd8d4f713fcab3a0e75e80a8fb000c92f21afe3 (diff)
downloadguix-b91e17243187d342a5d67cb61934dfb6567acfc6.tar.gz
gnu: Add emacs-highlight-defined.
* gnu/packages/emacs.scm (emacs-highlight-defined): New public variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 40fd389f11..cc21ad0580 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9875,3 +9875,25 @@ compilation/grep buffers.  Works with @code{wgrep}, @code{ack}, @code{ag},
 @code{shift-number-up} to increase and @code{shift-number-down} to
 decrease the number at point.")
     (license license:gpl3+)))
+
+(define-public emacs-highlight-defined
+  (package
+    (name "emacs-highlight-defined")
+    (version "0.1.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/Fanael/highlight-defined/archive/"
+             version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1ryd66989b5byqdw8jmjrjf0c78iiz72wibld750skcnj5h5h506"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/Fanael/highlight-defined")
+    (synopsis "Syntax highlighting of known Elisp symbols")
+    (description "Minor mode providing syntax highlighting of known Emacs Lisp
+symbols.  Currently the code distinguishes Lisp functions, built-in functions,
+macros, faces and variables.  To enable call @code{highlight-defined-mode}. ")
+    (license license:gpl3+)))