summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-01-03 16:00:44 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2020-01-03 16:04:52 +0100
commitba0e14061aab502999c29b71412b8dd7e6b00bac (patch)
tree4412d520b051814c90209ce754afa82cece12ed3 /gnu/packages
parent0715e520ead9b3188da41b31a691ab2e3c28fe31 (diff)
downloadguix-ba0e14061aab502999c29b71412b8dd7e6b00bac.tar.gz
gnu: mingetty: Fix cross-compilation.
* gnu/packages/admin.scm (mingetty)[arguments]: When cross-compiling, set CC
to the appropriate value in configure phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 1725f2a563..81f9f3b70e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -29,7 +29,7 @@
 ;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
-;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -520,13 +520,17 @@ login, passwd, su, groupadd, and useradd.")
      `(#:phases
        (modify-phases %standard-phases
          (replace 'configure
-           (lambda* (#:key inputs outputs #:allow-other-keys)
+           (lambda* (#:key inputs outputs target #:allow-other-keys)
              (let* ((out    (assoc-ref outputs "out"))
                     (man8   (string-append out "/share/man/man8"))
                     (sbin   (string-append out "/sbin"))
                     (shadow (assoc-ref inputs "shadow"))
                     (login  (string-append shadow "/bin/login")))
                (substitute* "Makefile"
+                 ,@(if (%current-target-system)
+                       '((("CC=.*$")
+                          (string-append "CC=" target "-gcc\n")))
+                       '())
                  (("^SBINDIR.*")
                   (string-append "SBINDIR = " out
                                  "/sbin\n"))