summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-06-29 23:12:13 +0200
committerLudovic Courtès <ludo@gnu.org>2020-06-30 00:18:28 +0200
commitbadd2161724b6fe7acd1da5144ebfe68ffc2b3b6 (patch)
treef77e8fab11a2fb475f291517d80c47b3794a41f4 /gnu/packages
parent4f060bf2fe1dd8bec79cb07907b46e16fca21398 (diff)
downloadguix-badd2161724b6fe7acd1da5144ebfe68ffc2b3b6.tar.gz
gnu: gcc-toolchain: Remove "glibc:debug" and "glibc:static" from "out".
With this change, the closure of "gcc-toolchain:out" goes from 1 GiB to
393 MiB, which was the intention.

* gnu/packages/commencement.scm (make-gcc-toolchain): Filter out
"libc-debug" and "libc-static" from OUT.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/commencement.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 59ef5d078b..ef250e037b 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3828,14 +3828,17 @@ COREUTILS-FINAL vs. COREUTILS, etc."
        '(#:modules ((guix build union))
          #:builder (begin
                      (use-modules (ice-9 match)
+                                  (srfi srfi-1)
                                   (srfi srfi-26)
                                   (guix build union))
 
                      (let ((out (assoc-ref %outputs "out")))
-
-                       (match %build-inputs
-                         (((names . directories) ...)
-                          (union-build out directories)))
+                       (union-build out
+                                    (filter-map (match-lambda
+                                                  (("libc-debug" . _) #f)
+                                                  (("libc-static" . _) #f)
+                                                  ((_ . directory) directory))
+                                                %build-inputs))
 
                        (union-build (assoc-ref %outputs "debug")
                                     (list (assoc-ref %build-inputs