summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2022-08-17 10:32:23 +0800
committer宋文武 <iyzsong@member.fsf.org>2022-08-22 08:42:54 +0800
commitbc89baeffe24fb38961ab050df778c95a34e63e2 (patch)
tree0a9012c446ac41a91ffdf28b3e0142ac4912645a /gnu/packages
parentfddf8dfa4e4f914f2d7d58b6eb7699cb99bc13bd (diff)
downloadguix-bc89baeffe24fb38961ab050df778c95a34e63e2.tar.gz
gnu: lxqt-panel: Update to 1.1.0.
* gnu/packages/lxqt.scm (lxqt-panel): Update to 1.1.0.
[inputs]: Add libxtst and xcb-util-image.
[arguments]: Remove patch-source and patch-translations-dir phases.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lxqt.scm21
1 files changed, 4 insertions, 17 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index dc0c7b9e44..aee43b32bb 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -509,14 +509,14 @@ of other programs.")
 (define-public lxqt-panel
   (package
     (name "lxqt-panel")
-    (version "0.17.1")
+    (version "1.1.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
                            version "/" name "-" version ".tar.xz"))
        (sha256
-        (base32 "1k2cfs1mhad486kh93vbxma3jpjksp4hzjv1xmp1g5alb5dgnc0q"))))
+        (base32 "11dg18ac6kj8qkkrg940bzpykjih6nnw8y3hfww3wiyg6dka9gd7"))))
     (build-system cmake-build-system)
     (inputs
      (list alsa-lib
@@ -530,6 +530,7 @@ of other programs.")
            libxdamage
            libxkbcommon
            libxrender
+           libxtst
            `(,lm-sensors "lib")
            lxqt-globalkeys
            pcre
@@ -539,6 +540,7 @@ of other programs.")
            qtx11extras
            solid
            xcb-util
+           xcb-util-image
            xkeyboard-config))
     (native-inputs
      (list pkg-config lxqt-build-tools qttools-5))
@@ -550,21 +552,6 @@ of other programs.")
      '(#:tests? #f                      ; no tests
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch-source
-           (lambda _
-             (substitute* '("autostart/CMakeLists.txt"
-                            "menu/CMakeLists.txt")
-               (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
-                "DESTINATION \"etc/xdg"))
-             #t))
-         (add-after 'unpack 'patch-translations-dir
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* '("cmake/BuildPlugin.cmake"
-                            "panel/CMakeLists.txt")
-               (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
-                (string-append (assoc-ref outputs "out")
-                               "/share/lxqt/translations")))
-             #t))
          (add-after 'unpack 'set-xkeyboard-config-file-path
                 (lambda* (#:key inputs #:allow-other-keys)
                   ;; Set the path to xkeyboard-config.