summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-17 20:18:44 +0000
committerLeo Famulari <leo@famulari.name>2016-08-18 17:23:27 -0400
commitc08533b2ccf37eaeedb336428c3b01a37249de06 (patch)
tree643b2d8a3d85a442201ee71930b600c75b2d8dc9 /gnu/packages
parent1166c283b7182c18c18503364df5a2772f458319 (diff)
downloadguix-c08533b2ccf37eaeedb336428c3b01a37249de06.tar.gz
gnu: Add interrobang.
* gnu/packages/admin.scm (interrobang): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 09a883c89c..6d88e3b72d 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1734,3 +1734,36 @@ highly portable.  Great for heterogenous networks.")
 the status of your battery in the system tray.")
     (home-page "https://github.com/valr/cbatticon")
     (license license:gpl2+)))
+
+(define-public interrobang
+  (let ((revision "1")
+        (commit "896543735e1c99144765fdbd7b6e6b5afbd8b881"))
+    (package
+      (name "interrobang")
+      (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "git://github.com/TrilbyWhite/interrobang")
+                      (commit commit)))
+                (file-name (string-append name "-" version))
+                (sha256
+                 (base32
+                  "1n13m70p1hfba5dy3i8hfclbr6k9q3d9dai3dg4jvhdhmxcpjzdf"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f ; no tests
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure)) ; no configure script
+         #:make-flags (list (string-append "PREFIX="
+                                           (assoc-ref %outputs "out")))))
+      (inputs
+       `(("libx11" ,libx11)))
+      (native-inputs
+       `(("pkg-config" ,pkg-config)))
+      (synopsis "Scriptable launcher menu")
+      (description "Interrobang is a scriptable launcher menu with a customizable
+shortcut syntax and completion options.")
+      (home-page "https://github.com/TrilbyWhite/interrobang")
+      (license license:gpl3+))))