summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaphaël Mélotte <raphael.melotte@mind.be>2020-09-17 18:58:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-09-21 09:59:32 +0300
commitc1e73d074c72d4427dde2c60ab47abeebec474a2 (patch)
treeb40f900897ddaeee7cf132c6b872189791efb0ba /gnu/packages
parent0a385196942bdd73b834b892b600a0fade076933 (diff)
downloadguix-c1e73d074c72d4427dde2c60ab47abeebec474a2.tar.gz
gnu: supertuxkart: Update to 1.2.
* gnu/packages/games.scm (supertuxkart): Update to 1.2.
[source]: Update snippet, some of the previously bundled libraries are
gone. Also update URL.
[arguments]: Remove unneeded configure flags.
[inputs]: Add sdl2.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 80d1659258..d04f702b34 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3464,15 +3464,15 @@ This game is based on the GPL version of the famous game TuxRacer.")
 (define-public supertuxkart
   (package
     (name "supertuxkart")
-    (version "1.1")
+    (version "1.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://sourceforge/supertuxkart/SuperTuxKart/"
-                           version "/supertuxkart-" version "-src.tar.xz"))
+                           version "/SuperTuxKart-" version "-src.tar.xz"))
        (sha256
         (base32
-         "1s0ai07g3sswck9mr0142989mrgzzq1njc1qxk5als5b245jpc79"))
+         "0dvx56hmy6wdhl7m9dw8zc1n3jqfp05gnxl6zs1rbfdyzl5dybh5"))
        (modules '((guix build utils)))
        (snippet
         ;; Delete bundled library sources
@@ -3480,12 +3480,9 @@ This game is based on the GPL version of the famous game TuxRacer.")
            ;; Supertuxkart uses modified versions of the Irrlicht engine
            ;; and the bullet library.  The developers gave an explanation
            ;; here: http://forum.freegamedev.net/viewtopic.php?f=17&t=3906
-           ;; FIXME: try to unbundle angelscript and libraqm
+           ;; FIXME: try to unbundle angelscript, libmcpp and libraqm
            (for-each delete-file-recursively
-                     '("lib/zlib"
-                       "lib/libpng"
-                       "lib/jpeglib"
-                       "lib/glew"
+                     '("lib/glew"
                        "lib/wiiuse"
                        "lib/enet"))
            #t))))
@@ -3494,19 +3491,16 @@ This game is based on the GPL version of the famous game TuxRacer.")
      `(#:tests? #f ; no check target
        #:configure-flags
        (list "-DUSE_WIIUSE=0"
-             ;; Do not use the bundled zlib, glew and enet.
-             "-DNO_IRR_COMPILE_WITH_ZLIB_=TRUE"
              "-DUSE_SYSTEM_GLEW=TRUE"
              "-DUSE_SYSTEM_ENET=TRUE"
              ;; In order to use the system ENet library, IPv6 support (added in
              ;; SuperTuxKart version 1.1) must be disabled.
              "-DUSE_IPV6=FALSE"
              ;; FIXME: needs libopenglrecorder
-             "-DBUILD_RECORDER=0"
-             ;; Irrlicht returns an integer instead of a boolean
-             "-DCMAKE_C_FLAGS=-fpermissive")))
+             "-DBUILD_RECORDER=0")))
     (inputs
      `(("glew" ,glew)
+       ("sdl2" ,sdl2)
        ("zlib" ,zlib)
        ("openal" ,openal)
        ("libvorbis" ,libvorbis)