summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 15:48:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:24 +0200
commitcd3c5b3a5e29a1f734d2207802d48096ee9935cd (patch)
tree6c71232cfc7dd60f670658ca4664962b1d5cccf8 /gnu/packages
parentcf4d8d84fa5a8b196cc1474143324adf289af6aa (diff)
downloadguix-cd3c5b3a5e29a1f734d2207802d48096ee9935cd.tar.gz
gnu: Add texlive-computational-complexity.
* gnu/packages/tex.scm (texlive-computational-complexity): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c5a48709cf..0018fce64f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2668,6 +2668,29 @@ font classes are typeset in and how many are defined (all of them or just the
 basic, most commonly used ones).")
     (license license:lppl1.3c)))
 
+(define-public texlive-computational-complexity
+  (package
+    (name "texlive-computational-complexity")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/computational-complexity/"
+                   "doc/latex/computational-complexity/"
+                   "source/latex/computational-complexity/"
+                   "tex/latex/computational-complexity/")
+             (base32
+              "12205p6i611vcywsvkq4qnkbgfyyrkxgrqhj93bfdy4n8y2802ir")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/computational-complexity")
+    (synopsis "Class for the journal Computational Complexity")
+    (description
+     "The LaTeX2e class @code{cc} was written for the journal Computational
+Complexity, and it can also be used for a lot of other articles.  You may like
+it since it contains a lot of features such as more intelligent references,
+a set of theorem definitions, an algorithm environment, and more.")
+    (license license:lppl1.2+)))
+
 (define-public texlive-crossrefenum
   (package
     (name "texlive-crossrefenum")