summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2013-05-08 20:46:13 +0000
committerNikita Karetnikov <nikita@karetnikov.org>2013-05-08 22:46:21 +0000
commitdcee3fc5a911ff64728cba85e245a5f151ae19a1 (patch)
treef14183706f92e167840d5ae1172a4a6432ed4d25 /gnu/packages
parent40506d5d925479cf024adbf14e39197550b5ab56 (diff)
downloadguix-dcee3fc5a911ff64728cba85e245a5f151ae19a1.tar.gz
gnu: Add GNU Bazaar.
* gnu/packages/bazaar.scm: New file.
* Makefile.am (MODULES): Add it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bazaar.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/bazaar.scm b/gnu/packages/bazaar.scm
new file mode 100644
index 0000000000..debaef88a1
--- /dev/null
+++ b/gnu/packages/bazaar.scm
@@ -0,0 +1,54 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages bazaar)
+  #:use-module ((guix licenses) #:select (gpl2+))
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system python)
+  #:use-module (guix build utils)
+  #:use-module ((gnu packages gettext)
+                #:renamer (symbol-prefix-proc 'guix:)))
+
+(define-public bazaar
+  (package
+    (name "bazaar")
+    (version "2.5.1")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "https://launchpad.net/bzr/2.5/" version
+                          "/+download/bzr-" version ".tar.gz"))
+      (sha256
+       (base32
+        "10krjbzia2avn09p0cdlbx2wya0r5v11w5ymvyl72af5dkx4cwwn"))))
+    (build-system python-build-system)
+    (inputs
+     ;; Note: 'tools/packaging/lp-upload-release' and 'tools/weavemerge.sh'
+     ;; require Zsh.
+     `(("gettext" ,guix:gettext)))
+    (arguments
+     `(#:tests? #f)) ; no test target
+    (home-page "https://gnu.org/software/bazaar")
+    (synopsis "Distributed and central version control system")
+    (description
+     "GNU Bazaar is a distributed version control system, which supports both
+central version control and distributed version control.  Developers can
+organize their workspace in whichever way they want.  It is possible to work
+from a command line or use a GUI application.")
+    (license gpl2+)))
\ No newline at end of file