summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2020-07-23 14:03:22 +0200
committerLudovic Courtès <ludo@gnu.org>2020-07-29 00:22:01 +0200
commitdf6fb956c56708b745ff5501ce0b943c30281ec5 (patch)
tree4c74002517b270e17a7fa4948088c14e7aae80d3 /gnu/packages
parent1b11e894b8b70cb6f8f08f8e11451bb687c7aa0a (diff)
downloadguix-df6fb956c56708b745ff5501ce0b943c30281ec5.tar.gz
gnu: Add python-sop.
* gnu/packages/python-crypto.scm (python-sop): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-crypto.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 7ea86d1f7b..ecf82f2078 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1474,3 +1474,34 @@ armored and binary formats.
 It can create and verify RSA, DSA, and ECDSA signatures, at the moment.  It
 can also encrypt and decrypt messages using RSA and ECDH.")
     (license license:bsd-3)))
+
+(define-public python-sop
+  (package
+    (name "python-sop")
+    (version "0.2.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "sop" version))
+        (sha256
+         (base32
+          "0gljyjsdn6hdmwlwwb5g5s0c031p6izamvfxp0d39x60af8k5jyf"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:tests? #f)) ; There are no tests, and unittest throws an error trying
+                     ; to find some:
+                     ;     TypeError: don't know how to make test from: 0.2.0
+    (home-page "https://gitlab.com/dkg/python-sop")
+    (synopsis "Stateless OpenPGP Command-Line Interface")
+    (description
+     "The Stateless OpenPGP Command-Line Interface (or sop) is a
+specification that encourages OpenPGP implementors to provide a common,
+relatively simple command-line API for purposes of object security.
+
+This Python module helps implementers build such a CLI from any implementation
+accessible to the Python interpreter.
+
+It does not provide such an implementation itself -- this is just the
+scaffolding for the command line, which should make it relatively easy to
+supply a handful of python functions as methods to a class.")
+    (license license:expat))) ; MIT license