summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2020-09-20 14:41:56 -0400
committerMark H Weaver <mhw@netris.org>2020-09-21 05:05:35 -0400
commite6b6e834903f001d4f2ae9bf0511bf7953c0f80b (patch)
tree212bd388751cd73f10e3e999c2e0ce33c47914e9 /gnu/packages
parent42a3db8cb795a9ef136e217902df6bd8e4c3e2eb (diff)
downloadguix-e6b6e834903f001d4f2ae9bf0511bf7953c0f80b.tar.gz
gnu: webkitgtk: Update to 2.30.0.
* gnu/packages/webkit.scm (webkitgtk): Update to 2.30.0.
[arguments]: Add "-DUSE_SYSTEMD=OFF" to the configure flags.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/webkit.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index d3fee105ef..0801bf7fa9 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -224,14 +224,14 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
 (define-public webkitgtk
   (package
     (name "webkitgtk")
-    (version "2.28.4")
+    (version "2.30.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.webkitgtk.org/releases/"
                                   "webkitgtk-" version ".tar.xz"))
               (sha256
                (base32
-                "0r4lkk21pny2g4mmsw0ds14m5hhjys1l47gvy59dfgihr7l546c2"))
+                "04axfmzsb9gnyqaz5v7ljapiycxnzwpiya1l9rhp4c1qsbrdpwya"))
               (patches (search-patches "webkitgtk-share-store.patch"
                                        "webkitgtk-bind-all-fonts.patch"))))
     (build-system cmake-build-system)
@@ -242,6 +242,7 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
        #:configure-flags (list
                           "-DPORT=GTK"
                           "-DENABLE_GTKDOC=ON" ; No doc by default
+                          "-DUSE_SYSTEMD=OFF"
                           (string-append ; uses lib64 by default
                            "-DLIB_INSTALL_DIR="
                            (assoc-ref %outputs "out") "/lib")