summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 15:48:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:26 +0200
commitecc0d6b00cc84ad2f0d3e46ab779b304ac80c24e (patch)
treeb4dc025a4cd83aa2fdadf041914ea86c1ed78d7f /gnu/packages
parent6480ed7d9d16416cc47d080e1c312366c148c0f6 (diff)
downloadguix-ecc0d6b00cc84ad2f0d3e46ab779b304ac80c24e.tar.gz
gnu: Add texlive-csassignments.
* gnu/packages/tex.scm (texlive-csassignments): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 310a270805..26bbcf3d82 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2837,6 +2837,30 @@ advantage terms but also flexible and powerful environments to layout
 game-based proofs or black-box reductions.")
     (license license:lppl1.3+)))
 
+(define-public texlive-csassignments
+  (package
+    (name "texlive-csassignments")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/csassignments/"
+                   "source/latex/csassignments/"
+                   "tex/latex/csassignments/")
+             (base32
+              "1gdrsh0iyg8dz0pnb9ak099qrznp54x37qqwd7kllw8jjzdcaqg1")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/csassignments")
+    (synopsis "Extend @code{article} class for computer science assignments")
+    (description
+     "This class wraps the default @code{article} and extends it for
+a homogeneous look of hand-in assignments at university (RWTH Aachen
+University, Computer Science Department), specifically in the field of
+computer science, but easily extensible to other fields.  It provides macros
+for structuring exercises, aggregating points, and displaying a grading table,
+as well as several macros for easier math mode usage.")
+    (license license:expat)))
+
 (define-public texlive-cweb-old
   (package
     (name "texlive-cweb-old")