summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-09 03:46:49 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-09 16:18:20 +0200
commitee861a54ab6ff62095a608340f83afbddf0133be (patch)
treec171e18670b1ba5c4873c798096da5a8bbaab751 /gnu/packages
parent88e1bce53e511c1c8ac260da30d28d5e6bdad692 (diff)
downloadguix-ee861a54ab6ff62095a608340f83afbddf0133be.tar.gz
gnu: radeontop: Don't use unstable tarball.
* gnu/packages/linux.scm (radeontop)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
[home-page]: Move down to its conventional spot.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 08bbb95ef3..36b4cb6c91 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4406,14 +4406,15 @@ developers.")
   (package
     (name "radeontop")
     (version "1.2")
-    (home-page "https://github.com/clbr/radeontop/")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append home-page "archive/v" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0jc3qs8m5hhbhxra4yslcq3vi179hvcwvdal80gsrgz6cj78zvfw"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/clbr/radeontop.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1b1m30r2nfwqkajqw6m01xmfhlq83z1qylyijxg7962mp9x2k0gw"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
@@ -4437,6 +4438,7 @@ developers.")
        ("libpciaccess" ,libpciaccess)
        ("libxcb" ,libxcb)
        ("ncurses" ,ncurses)))
+    (home-page "https://github.com/clbr/radeontop/")
     (synopsis "Usage monitor for AMD Radeon graphics")
     (description "RadeonTop monitors resource consumption on supported AMD
 Radeon Graphics Processing Units (GPUs), either in real time as bar graphs on