summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-08-18 02:16:14 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2019-08-18 21:00:21 +0300
commiteff412ed3b7add0a32fdf681950fa1e791d4af04 (patch)
tree9c4b552525bff729a41267a165574b18284b8252 /gnu/packages
parent7fd14950791c0cc254df2bcf4abffcdbff6d0bcf (diff)
downloadguix-eff412ed3b7add0a32fdf681950fa1e791d4af04.tar.gz
gnu: Add emacs-evil-owl.
* gnu/packages/emacs-xyz.scm (emacs-evil-owl): New variable.

Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 84ae7a1357..a4708a1d85 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6553,6 +6553,33 @@ used for reverse direction.")
 end of a line and increment or decrement it.")
       (license license:gpl3+))))
 
+(define-public emacs-evil-owl
+  (let ((commit "36a5fe057f44d48e377e3ef4f04b4eb30e1af309")
+        (revision "1"))
+    (package
+      (name "emacs-evil-owl")
+      (version (git-version "0.0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mamapanda/evil-owl")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "07a6n0gqss1qx9a50dqzqqq0gj6n7a4ykbcv1a0c9qd4fnfnm90m"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-evil" ,emacs-evil)
+         ("emacs-posframe" ,emacs-posframe)))
+      (home-page "https://github.com/mamapanda/evil-owl")
+      (synopsis "Preview candidates when using Evil registers and marks")
+      (description
+       "This package supplements Evil's register- and mark-based commands with
+a popup window for previewing candidates.")
+      (license license:gpl3+))))
+
 (define-public emacs-evil-exchange
   (let ((commit "47691537815150715e64e6f6ec79be7746c96120")
         (version "0.41")