summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-13 14:33:55 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:07 +0100
commitf2516de2fc7459d8ceed1779f0f24840075d08d6 (patch)
tree779150f1073b555f78e119a2bb92b3790a311265 /gnu/packages
parent328bb95d3507682f5e06fb2880c632252f59ee57 (diff)
downloadguix-f2516de2fc7459d8ceed1779f0f24840075d08d6.tar.gz
gnu: Fix python inputs, part 7: Ensure python-cython is a native-input.
* gnu/packages/audio.scm (python-pyliblo): [inputs] Move python-cyton to
  [native-inputs].
* gnu/packages/bioinformatics.scm (python2-pybedtools): dito.
* gnu/packages/music.scm (beast, python-pyportmidi): dito.
* gnu/packages/python.scm (python2-fastlmm, python-kivy): dito.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/audio.scm5
-rw-r--r--gnu/packages/bioinformatics.scm6
-rw-r--r--gnu/packages/music.scm8
-rw-r--r--gnu/packages/python.scm6
4 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 7d2e2d2a4b..5e32081293 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1434,9 +1434,10 @@ implementation of the Open Sound Control (OSC) protocol.")
                "13vry6xhxm7adnbyj28w1kpwrh0kf7nw83cz1yq74wl21faz2rzw"))))
     (build-system python-build-system)
     (arguments `(#:tests? #f)) ;no tests
+    (native-inputs
+     `(("python-cython" ,python-cython)))
     (inputs
-     `(("python-cython" ,python-cython)
-       ("liblo" ,liblo)))
+     `(("liblo" ,liblo)))
     (home-page "http://das.nasophon.de/pyliblo/")
     (synopsis "Python bindings for liblo")
     (description
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9cfb30023f..9b47dc3d51 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -522,13 +522,13 @@ intended to behave exactly the same as the original BWK awk.")
     (build-system python-build-system)
     (arguments `(#:python ,python-2)) ; no Python 3 support
     (inputs
-     `(("python-cython" ,python2-cython)
-       ("python-matplotlib" ,python2-matplotlib)))
+     `(("python-matplotlib" ,python2-matplotlib)))
     (propagated-inputs
      `(("bedtools" ,bedtools)
        ("samtools" ,samtools)))
     (native-inputs
-     `(("python-pyyaml" ,python2-pyyaml)
+     `(("python-cython" ,python2-cython)
+       ("python-pyyaml" ,python2-pyyaml)
        ("python-nose" ,python2-nose)))
     (home-page "https://pythonhosted.org/pybedtools/")
     (synopsis "Python wrapper for BEDtools programs")
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 61bcd3785b..caebe70dd6 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1022,7 +1022,6 @@ Laurens Hammond and Don Leslie.")
      `(("rapicorn" ,rapicorn)
        ("guile" ,guile-1.8)
        ("python" ,python-2)
-       ("cython" ,python2-cython)
        ("libgnomecanvas" ,libgnomecanvas)
        ("libogg" ,libogg)
        ("libmad" ,libmad)
@@ -1033,6 +1032,7 @@ Laurens Hammond and Don Leslie.")
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("glib:bin" ,glib "bin")
+       ("cython" ,python2-cython)
        ("perl" ,perl)
        ("perl-xml-parser" ,perl-xml-parser)))
     (home-page "https://testbit.eu/wiki/Beast_Home")
@@ -1315,10 +1315,10 @@ using a system-independent interface.")
              #t)))))
     (inputs
      `(("portmidi" ,portmidi)
-       ("alsa-lib" ,alsa-lib)
-       ("python-cython" ,python-cython)))
+       ("alsa-lib" ,alsa-lib)))
     (native-inputs
-     `(("unzip" ,unzip)))
+     `(("python-cython" ,python-cython)
+       ("unzip" ,unzip)))
     (home-page "http://portmedia.sourceforge.net/portmidi/")
     (synopsis "Python bindings to PortMidi")
     (description
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3442488d29..35d9021165 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10542,10 +10542,10 @@ and/or Xon/Xoff.  The port is accessed in RAW mode.")
                                     "/include/SDL2"))
              #t)))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("pkg-config" ,pkg-config)
+       ("python-cython" ,python-cython)))
     (inputs
-     `(("python-cython" ,python-cython)
-       ("gstreamer" ,gstreamer)
+     `(("gstreamer" ,gstreamer)
        ("mesa" ,mesa)
        ("sdl-union"
         ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))