summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-05-26 03:26:55 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-05-26 03:27:33 +0200
commitf3addff21c074e3f655d2108be6a21b93f598498 (patch)
treed7dcf8b026318a0dc3ac314e283c5b40444f8ad1 /gnu/packages
parentdbe2dfa5289924a8eb218137111a169ab3ab91ff (diff)
downloadguix-f3addff21c074e3f655d2108be6a21b93f598498.tar.gz
gnu: libelf: Use archived home page and mirrored source.
* gnu/packages/elf.scm (libelf)[source]: Use mirror URLs.
[home-page]: Use archived home page.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/elf.scm23
1 files changed, 15 insertions, 8 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 09be3a75a3..4f365cf205 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -160,13 +160,19 @@ static analysis of the ELF binaries at hand.")
   (package
     (name "libelf")
     (version "0.8.13")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "http://www.mr511.de/software/libelf-"
-                                 version ".tar.gz"))
-             (sha256
-              (base32
-               "0vf7s9dwk2xkmhb79aigqm0x0yfbw1j0b9ksm51207qwr179n6jr"))))
+    (source
+     (origin
+       (method url-fetch)
+       (uri (list
+             ;; As of May 2019, the original URL at mr511.de redirects to a
+             ;; domain that doesn't resolve.  Use these two mirrors instead.
+             (string-append "https://fossies.org/linux/misc/old/"
+                            "libelf-" version ".tar.gz")
+             (string-append "https://ftp.osuosl.org/pub/blfs/conglomeration/"
+                            "libelf/libelf-" version ".tar.gz")))
+       (sha256
+        (base32
+         "0vf7s9dwk2xkmhb79aigqm0x0yfbw1j0b9ksm51207qwr179n6jr"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
@@ -183,7 +189,8 @@ static analysis of the ELF binaries at hand.")
                                        (%current-system))
                              '("--host=aarch64-unknown-linux-gnu")
                              '()))))))))
-    (home-page "http://www.mr511.de/software/english.html")
+    (home-page (string-append "https://web.archive.org/web/20181111033959/"
+                              "http://www.mr511.de/software/english.html"))
     (synopsis "ELF object file access library")
     (description "Libelf is a C library to access ELF object files.")
     (license lgpl2.0+)))