summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-04-12 10:02:22 -0500
committerEric Bavier <bavier@member.fsf.org>2016-05-12 19:59:52 +0000
commitf622e2123b578d9fea6d967a69492cc2041ce348 (patch)
treed76afec1b52c65f8c3f47d587d17493875db4e84 /gnu/packages
parent04b7a7cd10ee2509d350ac4933b8964235376d41 (diff)
downloadguix-f622e2123b578d9fea6d967a69492cc2041ce348.tar.gz
gnu: hdf5: Patch output references to zlib.
* gnu/packages/maths.scm (hdf5)[arguments]: Use modify-phases.  Add
'patch-references' phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm19
1 files changed, 13 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 877bfd400b..4a10f6feb0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -420,12 +420,19 @@ plotting engine by third-party applications like Octave.")
      `(("zlib" ,zlib)))
     (arguments
      `(#:phases
-        (alist-cons-before
-         'configure 'patch-configure
-         (lambda _
-           (substitute* "configure"
-             (("/bin/mv") "mv")))
-         %standard-phases)))
+       (modify-phases %standard-phases
+         (add-before 'configure 'patch-configure
+           (lambda _
+             (substitute* "configure"
+               (("/bin/mv") "mv"))))
+         (add-after 'install 'patch-references
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((bin (string-append (assoc-ref outputs "out") "/bin"))
+                   (zlib (assoc-ref inputs "zlib")))
+               (substitute* (find-files bin "h5p?cc")
+                 (("-lz" lib)
+                  (string-append "-L" zlib "/lib " lib)))
+               #t))))))
     (home-page "http://www.hdfgroup.org")
     (synopsis "Management suite for extremely large and complex data")
     (description "HDF5 is a suite that makes possible the management of