summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2014-09-25 12:29:43 +0400
committerAlex Kost <alezost@gmail.com>2014-09-26 09:23:10 +0400
commitf7d28082bb4617d401c20dea0a8a30f877551f04 (patch)
treef27ccd2416c3d8acfc1a8cf69b092e93813c1949 /gnu/packages
parent76d88cfa57e20f04b4cd305d7522991dc2423667 (diff)
downloadguix-f7d28082bb4617d401c20dea0a8a30f877551f04.tar.gz
gnu: Add giblib.
* gnu/packages/image.scm (giblib): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/image.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index a9c3a5df16..0e79942f19 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -265,3 +265,30 @@ more modular, simple, and flexible.")
     ;; This license adds several sentences to the original X11 license.
     (license (license:x11-style "file://COPYING"
                                 "See 'COPYING' in the distribution."))))
+
+(define-public giblib
+  (package
+    (name "giblib")
+    (version "1.2.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://linuxbrit.co.uk/downloads/giblib-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1b4bmbmj52glq0s898lppkpzxlprq9aav49r06j2wx4dv3212rhp"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("libx11" ,libx11)
+       ("imlib2" ,imlib2)))
+    (home-page "http://linuxbrit.co.uk/software/") ; no real home-page
+    (synopsis "Wrapper library for imlib2")
+    (description
+     "giblib is a simple library which wraps imlib2's context API, avoiding
+all the context_get/set calls, adds fontstyles to the truetype renderer and
+supplies a generic doubly-linked list and some string functions.")
+    ;; This license removes a clause about X Consortium from the original
+    ;; X11 license.
+    (license (license:x11-style "file://COPYING"
+                                "See 'COPYING' in the distribution."))))