summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-06-23 05:43:09 +0200
committerLudovic Courtès <ludo@gnu.org>2017-06-23 14:16:44 +0200
commitf817b4d9039e9a8d4ac0b4034f79a60f530296de (patch)
tree59598136448344143c4fe0811dbcb7b25167b511 /gnu/packages
parent21ab5949177aae2d222d690948e5e54ca541dfc6 (diff)
downloadguix-f817b4d9039e9a8d4ac0b4034f79a60f530296de.tar.gz
gnu: Add python2-pyopengl.
* gnu/packages/python.scm (python2-pyopengl): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3c3b4056d4..d9e004ecbe 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -42,6 +42,7 @@
 ;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2017 Kei Kebreau <kei@openmailbox.org>
+;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -15449,3 +15450,25 @@ functionality like full case-folding for case-insensitive matches in Unicode.")
 
 (define-public python2-regex
   (package-with-python2 python-regex))
+
+(define-public python2-pyopengl
+  (package
+   (name "python2-pyopengl")
+   (version "3.1.0")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (pypi-uri "PyOpenGL" version))
+     (sha256
+      (base32
+       "1byxjj6a8rwzhxhjqlc588zdad2qwxdd7vlam2653ylll31waiwv"))))
+   (arguments
+     `(#:python ,python-2))
+   (build-system python-build-system)
+   (home-page "http://pyopengl.sourceforge.net")
+   (synopsis "Standard OpenGL bindings for Python")
+   (description
+    "PyOpenGL is the most common cross platform Python binding to OpenGL and
+related APIs.  The binding is created using the standard @code{ctypes}
+library.")
+   (license license:bsd-3)))