summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-04-19 22:57:44 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:44 +0200
commitf96097da8ac3a5e0e818608cc4b4848a00362c00 (patch)
tree5f21c709e9440046d2d7e411e078f4aea8bc4736 /gnu/packages
parent8c28fbc3bef2c4ece6fb07a0b81a35fb89b85db3 (diff)
downloadguix-f96097da8ac3a5e0e818608cc4b4848a00362c00.tar.gz
gnu: Add rust-webpki-roots-0.18.
* gnu/packages/crates-io.scm (rust-webpki-roots-0.18): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9ade4b73d6..b42cd82241 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -26687,6 +26687,25 @@ Verification.")
        #:cargo-development-inputs
        (("rust-base64" ,rust-base64-0.9))))))
 
+(define-public rust-webpki-roots-0.18
+  (package
+    (name "rust-webpki-roots")
+    (version "0.18.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "webpki-roots" version))
+      (file-name (string-append name "-" version ".tar.gz"))
+      (sha256
+       (base32 "1d4ss607rgi9pj01zzqa13c1p3m35z314yh6lmjaj4kzvwv5gkci"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-webpki" ,rust-webpki-0.21))))
+    (home-page "https://github.com/ctz/webpki-roots")
+    (synopsis "Mozilla's CA root certificates for use with webpki")
+    (description "Mozilla's CA root certificates for use with webpki")
+    (license license:mpl2.0)))
+
 (define-public rust-weedle-0.10
   (package
     (name "rust-weedle")