summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-08-19 00:52:49 +0200
committerLudovic Courtès <ludo@gnu.org>2013-08-19 00:52:49 +0200
commitf99f6fd6fa5c55f490fad7f4e444ef8a835db2ac (patch)
treeff2d53eaaf9108c76d9921f22fafe40fdb66e26b /gnu/packages
parent482f8a07e33dc47d52e41a32461c537013851380 (diff)
downloadguix-f99f6fd6fa5c55f490fad7f4e444ef8a835db2ac.tar.gz
gnu: Add GNU Ocrad.
* gnu/packages/ocrad.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocrad.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/ocrad.scm b/gnu/packages/ocrad.scm
new file mode 100644
index 0000000000..f6bc112a8c
--- /dev/null
+++ b/gnu/packages/ocrad.scm
@@ -0,0 +1,53 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ocrad)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module ((gnu packages compression)
+                #:select (lzip)))
+
+(define-public ocrad
+  (package
+    (name "ocrad")
+    (version "0.22")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://gnu/ocrad/ocrad-"
+                                 version ".tar.lz"))
+             (sha256
+              (base32
+               "1zcqa4ydcmmhzyg730wywnmkjv2x2av3r875vwz69k69yjydrjfn"))))
+    (build-system gnu-build-system)
+    (native-inputs `(("lzip" ,lzip)))
+    (home-page "http://www.gnu.org/software/ocrad/")
+    (synopsis "Optical character recognition based on feature extraction")
+    (description
+     "GNU Ocrad is an OCR (Optical Character Recognition) program based on a
+feature extraction method.  It reads images in pbm (bitmap), pgm
+ (greyscale) or ppm (color) formats and produces text in byte (8-bit)
+or UTF-8 formats.
+
+Also includes a layout analyser able to separate the columns or blocks of text
+normally found on printed pages.
+
+Ocrad can be used as a stand-alone console application, or as a backend to
+other programs.")
+    (license gpl3+)))