summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-11-26 21:01:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-11-27 09:58:28 +0100
commitf9bd82e7a6e4e991be3f3cc6bf8bccd7feeb5241 (patch)
tree88708bdf7a61547d5098f183908b7d6e6b8d0a4c /gnu/packages
parentfbecb5cddb2d36cc1a29dac3751b017fa531383c (diff)
downloadguix-f9bd82e7a6e4e991be3f3cc6bf8bccd7feeb5241.tar.gz
gnu: python-seaborn: Add patch to fix tests.
* gnu/packages/python-xyz.scm (python-seaborn)[source]: Add upstream patch to
fix test failures.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 684a41f70c..c89df24dd4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6265,7 +6265,19 @@ SVG, EPS, PNG and terminal output.")
        (method url-fetch)
        (uri (pypi-uri "seaborn" version))
        (sha256
-        (base32 "0bqysi3fxfjl1866m5jq8z7mynhqbqnikim74dmzn8539iwkzj3n"))))
+        (base32 "0bqysi3fxfjl1866m5jq8z7mynhqbqnikim74dmzn8539iwkzj3n"))
+       (patches
+        (list (origin
+                (method url-fetch)
+                ;; This has already been merged, but there is no new
+                ;; release including this patch.  It fixes problems
+                ;; with axis rotation that would lead to test
+                ;; failures.
+                (uri "https://patch-diff.githubusercontent.com/raw/mwaskom/seaborn/pull/1716.diff")
+                (sha256
+                 (base32
+                  "1lm870z316n9ivsyr86hpk1gxaraw0mrjvq42lqsm0znhjdp9q9w"))
+                (file-name "seaborn-0.9.0-axis-rotation.patch"))))))
     (build-system python-build-system)
     (arguments
      `(#:phases