summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-03-21 00:46:36 +0530
committerLeo Famulari <leo@famulari.name>2017-03-21 15:15:35 -0400
commitfb731c92328fb3aa931e771a567738a565d4ada8 (patch)
tree87b4da2402b025ec073ddb5f05eece7fb7bd329e /gnu/packages
parent8ea71f20050f9faf1f1faba4b02216436aee783d (diff)
downloadguix-fb731c92328fb3aa931e771a567738a565d4ada8.tar.gz
gnu: Add megaglest-data.
* gnu/packages/games.scm (megaglest-data): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a8fdd341c7..56f479e932 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -25,6 +25,7 @@
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2016 Steve Webber <webber.sl@gmail.com>
 ;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
+;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3339,3 +3340,25 @@ This command works on piped data.  Pipe any ASCII or UTF-8 text to nms, and
 it will apply the hollywood effect, initially showing encrypted data, then
 starting a decryption sequence to reveal the original plaintext characters.")
     (license license:expat)))
+
+(define-public megaglest-data
+  (package
+    (name "megaglest-data")
+    (version "3.13.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/MegaGlest/megaglest-data"
+             "/releases/download/" version "/megaglest-data-"
+             version ".tar.xz"))
+       (sha256
+        (base32
+         "0ipgza33z89fw3si32iafm981f3fvm0zldvbxj29whghd2k3rpj3"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f))
+    (home-page "https://megaglest.org/")
+    (synopsis "Data files for MegaGlest")
+    (description "This package contains the data files required for MegaGlest.")
+    (license license:cc-by-sa3.0)))