summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-01 23:55:03 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:00 -0500
commit081d85d6f426524b7df2659ea419e4bdf033e9a6 (patch)
tree994ed40f63570de5812703ed2091b5542534dbb0 /gnu/packages
parent0a702df90febab5ae19e6b35afdaae463a94f159 (diff)
downloadguix-081d85d6f426524b7df2659ea419e4bdf033e9a6.tar.gz
gnu: Add ghc-sop-core.
* gnu/packages/haskell-xyz.scm (ghc-sop-core): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 44edf2b95b..57c1ce71ab 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9368,6 +9368,29 @@ automatically by SmallCheck.")
      "This library provides a SOCKS proxy (version 5) implementation.")
     (license license:bsd-3)))
 
+(define-public ghc-sop-core
+  (package
+    (name "ghc-sop-core")
+    (version "0.4.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "sop-core/sop-core-" version ".tar.gz"))
+       (sha256
+        (base32
+         "07ci2mh8cbjvipb576rxsj3iyhkj5c5dnsns4xkdppp2p3pv10d3"))))
+    (build-system haskell-build-system)
+    (home-page "http://hackage.haskell.org/package/sop-core")
+    (synopsis "True Sums of Products")
+    (description "This package provides an implementation of
+@math{n}-ary sums and @math{n}-ary products.  The module @code{Data.SOP}
+is the main module of this library and contains more detailed
+documentation.  The main use case of this package is to serve as the
+core of @url{https://hackage.haskell.org/package/generics-sop,
+generics-sop}.")
+    (license license:bsd-3)))
+
 (define-public ghc-split
   (package
     (name "ghc-split")